Updated vagrant packages for fedora

Vagrant-1.1.2 was released upstream a few days ago, so I have updated my fedora packages.

A yum repo for Fedora 18 with rubygem-vagrant, and all deps and builddeps is available at http://users.linpro.no/ingvar/vagrant/

Missing deps in Fedora:

  • rubygem-childprocess >=0.3.7 < 0.4.0 (0.3.6 in rawhide)
    Fix: Update package to 0.3.7

  • rubygem-json >= 1.6.6 < 1.7.0 (1.6.8 in f18, 1.7.5 in rawhide)
    Fix: f18 works, but rawhide will be broken

  • rubygem-log4r >= 1.1.9 < 2.0.0
    Fix: Build new package, bz #905240

  • rubygem-net-ssh >= 2.6.6 (2.2.1 in f18)
    Fix: rebuild f18 package from rawhide

  • rubygem-net-scp >= 1.1.0 (1.0.4 in rawhide)
    Fix: Update package to 1.1.0

According to the gemspec, it needs rspec-* ~> 2.11.0, but it seems to build fine with 2.8.0 from f18

rubygem-vagrant was submitted for package review in bz #905396.

2 Responses to “Updated vagrant packages for fedora”

  1. Christof says:

    With the package from your repository I get the following error:

    $ vagrant status
    /usr/share/rubygems/rubygems/custom_require.rb:36:in `require’: cannot load such file — log4r (LoadError)
    from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require’
    from /usr/bin/vagrant:8:in `’

    Your log4r package is installed though:

    $ rpm -q rubygem-log4r
    rubygem-log4r-1.1.10-1.fc18.noarch

Leave a Reply